Partage
  • Partager sur Facebook
  • Partager sur Twitter

React-Native navigation-tabs

Unable to resolve "react-navigation-tabs" from ...

Sujet résolu
    2 octobre 2019 à 22:02:52

    Bonjour à tous,

    alors voilà j'ai une erreur avec react-navigation-tabs dans le chapitre ""Implémentez une navigation avancée" dans le cours Développez une application mobile React Native.

    je vous ai mis une capture d'écran de mon code, la VM et du Terminal

    ça fait 2/3 jours que je ne trouve aucune solution dessus.

    Encore merci pour votre aide :)

    • Partager sur Facebook
    • Partager sur Twitter
      7 octobre 2019 à 16:27:06

      createBottomTabNavigator provient bien de 'react-navigation-tabs' ?

      Sur la doc elle est importé directement depuis react-navigation alors essaie : 

      import { createAppContainer, createBottomTabNavigation } from 'react-navigation'



      -
      Edité par Ozxlol 7 octobre 2019 à 16:32:26

      • Partager sur Facebook
      • Partager sur Twitter
        8 novembre 2019 à 10:34:26

        Le sujet est passé en Résolu alors que la solution n'a pas marché pour moi.

        Il faut bien importer avec : 

        import { createBottomTabNavigator } from 'react-navigation-tabs'

        Puis faire : npm --save install react-navigation-tabs

        et enfin : npm --save install react-native-reanimated

        Voila j’espère n'avoir rien oublié 

        • Partager sur Facebook
        • Partager sur Twitter

        React-Native navigation-tabs

        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
        • Editeur
        • Markdown