Partage
  • Partager sur Facebook
  • Partager sur Twitter

Tester un Quartz

Montage décompteur sans µC

    12 août 2011 à 11:42:48

    Mise en contexte


    Bonjour à tous,
    pratiquant le paintball, je participe souvent à des parties à fortes immersion. Dans cette optique est avec ma formation en électronique (BEP électronique et Bac STI électronique) j'ai entrepris de réaliser un montage décompteur.
    Du fait de mon amateurisme et de ma non-volonté (pour l'instant) d'investir dans un programmateur pour µC, je souhaitais réaliser un montage avec uniquement des composants classiques.

    Voici mon cahier des charges :
    • - Décompter entre 5min et 1h maxi
    • - Affichage du décompte
    • - Bouton d'arrêt du décompte
    • - Signal sonore audible à plus de 50m dans un environnement bruyant pendant 5sec max
    • - Montage portable (format valise ou caisse de munition)
    • - Interface simple


    Pour le plus simple niveau interface j'ai choisit 4 afficheurs 7 segments, une rampe de 10 microswitchs pour le réglage du décompte avec un pas de 5min entre chaque réglage (5min, 10min, 15min, ...), le bouton d'arrêt est un bouton coup de poing. En ce qui concerne l'alimentation mon choix s'est porté sur une batterie 12v de type motoculture (pour tracteur tondeuse et compagnie). Le signal sonore devant être audible au milieu du vacarme de notre guerre colorisée j'ai pensé utiliser une alarme automobile (son aigu et fort) mais j'ai encore des doutes sur la consommation électrique d'un tel montage.


    Schéma


    Mon schéma au format Proteus : http://www.megaupload.com/?d=XR0QHGXS.
    A noter que le dipôle quartz ne fonctionne pas avec le CD4060 sur Proteus, je l'ai donc remplacé par un schéma équivalent.

    Pour faire une explication assez brève, le quartz et le CD4060 suivent par la bascule D génèrent un signal 1Hz (1sec) que je transmets aux CD4029 qui décomptent à partir du chiffre chargé par mon réseau de diodes et la rampe de microswitchs. Enfin les CD4543 font la conversion 7 segments pour l'affichage.
    J'ai mis la partie sonore de coté pour l'instant, car je n'ai pas fixé mon choix.

    Je suis passé à la réalisation de ce montage car mes simulations sur Proteus étaient concluantes. Mais le montage "n'a pas l'air" de fonctionner. Après vérification de mon câblage sur plusieurs points j'ai éliminé quelques problèmes sur l'affichage qui était par exemple inversé. En forçant les entrées de mes CI j'ai pu tester tous les chiffres sur tous mes afficheurs et donc valider leur fonctionnement et câblage.
    Maintenant le problème se situe sur mon oscillateur.


    Question


    Je n'ai pas étudié les quartz et je ne connais que vulgairement leur fonctionnement. Pour vérifier mon oscillateur j'ai essayé de relever la tension sur la sortie Q de la bascule en me disant que celle-ci variant à la seconde je devrais voir la variation au multimètre. Mais aucune variation, je souhaiterais donc savoir comment tester un quartz le plus simplement possible?

    Je suis conscient que mon montage ne va pas dans le sens de l'électronique actuel qui vise de plus en plus à faire de l'embarqué avec les µC mais je n'ai pas l'intention de dépenser de l'argent juste pour réaliser cet accessoire de jeu.
    • Partager sur Facebook
    • Partager sur Twitter
      16 août 2011 à 13:54:43

      Salut,

      Je n'ai pas Proteus donc je n'ai pas ouvert ton schéma mais voici une piste de recherche :
      Comment est placé ton circuit oscillant ?? (couple quartz et condensateur)

      Ils doivent-être placé le plus près possible des entrées sur lequel sont placés les broches du quartz.

      Vérifie aussi que tu as mis de bonnes valeurs sur les condensateurs pour l'oscillation.

      A l'époque ou je faisais des circuits avec des microcontrolleur, ces problèmes revenait souvent aux débutants.
      Si tu places des mauvais condos, ca n'oscille pas (pour du 20MHz on avait du 33pF il me semble).
      Si tu places le quartz trop loin, les pistes de cuivres ont un effet capacitif qui vire ton oscillation...

      Peut-tu mettre des photos du montage ??
      • Partager sur Facebook
      • Partager sur Twitter
        21 août 2011 à 22:21:14

        > j'ai encore des doutes sur la consommation électrique d'un tel
        > montage.

        Ton format (valise) et ta batterie (grosse) font que tu n'auras aucun problème, une batterie 12V au plomb ça peut débiter des ampères... N'oublie pas de la charger de temps en temps par contre, car une batterie plomb trop déchargée est foutue. Ajoute une ligne de code pour surveiller la tension de la batterie (ah pardon t'as pas de uC, ajoute un TL431, trois résistances et une LED).

        Tu peux mettre un klaxon de bagnole (10€ dans une casse) mais il te faudra un bon gros MOSFET pour le commuter.

        > Mon schéma au format Proteus

        Dommage. Mets-le en PDF.

        Tu n'as pas oublié les capas autour du quartz ?

        > je n'ai pas l'intention de dépenser de l'argent juste pour
        > réaliser cet accessoire de jeu

        Un arduino (qui comprend le microcontroleur et est programmable par usb sans programmateur spécial à part un câble) coûte dans les 20€.
        • Partager sur Facebook
        • Partager sur Twitter
          21 août 2011 à 22:59:10

          Citation : Lord Casque Noir

          Un arduino (qui comprend le microcontroleur et est programmable par usb sans programmateur spécial à part un câble) coûte dans les 20€.



          Arduino c'est bien mais faut arreter de vouloir en mettre partout...
          En l'état son montage utilise juste quelques betes composants, pas la peine d'aller s'embeter à embarquer de la prog avec un Arduino...
          • Partager sur Facebook
          • Partager sur Twitter
            8 septembre 2011 à 13:49:52

            Excusez ma réponse tardive.

            Vous trouverez ici : http://www.megaupload.com/?d=ROJJKP8W mon schéma au format PDF.
            De plus une photo de mon montage à cette adresse : http://img695.imageshack.us/img695/4743/photoefmd.jpg. Où l'on voit le Quartz assez proche de du 4060 (en dessous du bornier) et les 2 condensateurs (bord violet) pas très loin non plus

            Je vais regarder ce qu'apporte un Arduino mais en attendant je voudrais faire fonctionner ce montage (si possible).

            Merci de vos réponses.
            • Partager sur Facebook
            • Partager sur Twitter
              8 septembre 2011 à 21:11:00

              C'est vrai qu'il est assez proche... maintenant faut voir si les capas ne sont pas elles trop loin (et genre relié avec gros paté d'étain qui fait une petite capacité supplémentaire), et surtout sont-elles de bonnes valeurs...
              • Partager sur Facebook
              • Partager sur Twitter
                8 octobre 2011 à 22:28:12

                La valeur des condensateurs est bonne car je les ai acheté dans un magasin d'électronique. Par contre pour les connexions ce sont des petits patté de soudure vu le type de plaque utilisé. Je vais essayer de remplacer mes soudures par des fils pour diminuer cette capacité.

                Merci de ton aide.
                • Partager sur Facebook
                • Partager sur Twitter
                  16 octobre 2011 à 4:59:14

                  Hola,

                  Je n'ai pas regarde le schéma dans le détail, mais je vois déjà un problème avec ton transistor Q2, le courant de sortie de U13B (famille CMOS) ne sera pas suffisant pour le saturer correctement. Prendre plutôt un mosfet (canal P).
                  Ensuite la résistance R11 est un peu élevé (prendre plutôt 220 Ohms) sauf si tu utilise une LED a haut rendement. De plus, il faut découpler chaque CI par un condo de 100nF si tu ne veux pas avoir de problèmes. En général pour un quartz et sur un micro pross on met des condos de 10 a 33 pF, change tes condos car 220 pf me semble tout de même élevé, tu peux prendre 22pF, ensuite si cela ne marche toujours pas change la valeur de R15 par une valeur plus grande. En dernier recours, remplace un des 22 pF par un 33pF pour permettre un "déséquilibre" pour qu'il démarrage.
                  Pour vérifier le quartz, c'est avec un scope sur une des sortie de ton 4060.
                  Je pense qu'avec un simple multimètre sur la patte 1 de U2 tu devrais voir des changements.
                  A+
                  Bonne manip
                  • Partager sur Facebook
                  • Partager sur Twitter

                  Tester un Quartz

                  × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                  × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                  • Editeur
                  • Markdown