Partage

lien vers css

aide svp

Anonyme
16 août 2009 à 18:40:34

bonjour a tous les zeros , j'ai besoin de votre aide , je n'arrive pas a relativiser un lien vers le dossier css voici mon index.html:


<html>
<head>
<title>bienvenue sur actufoot</title>

<meta name="generator" content="namo webeditor v5.0">
<link rel="stylesheet" type="text/css" href="style.css" />
</head>
<body bgcolor=#ffffff leftmargin=0 topmargin=0 marginwidth=0 marginheight=0>
<p align="center"><!-- imageready slices (sans titre-1) --><table width=800 border=0 cellpadding=0 cellspacing=0 align="center">
	<tr>
		<td rowspan=10>
			<img src="images/index_01.jpg" width=24 height=238 alt=""></td>
		<td colspan=3>
			<img src="images/index_02.jpg" width=751 height=18 alt=""></td>
		<td rowspan=10>
			<img src="images/index_03.jpg" width=25 height=238 alt=""></td>
	</tr>
	<tr>
		<td rowspan=8>
			<img src="images/index_04.jpg" width=289 height=210 alt=""></td>
		<td>
			<img src="images/index_05.jpg" width=189 height=30 alt=""></td>
		<td rowspan=7>
			<img src="images/index_06.jpg" width=273 height=153 alt=""></td>
	</tr>
	<tr>
	<div 
		<td height="20" background="images/index_07.jpg">
			<span style="font-size:8pt; letter-spacing:1;"><font face="tahoma" color="white">&nbsp;&nbsp;<a href="index.html">accueil</a></font></span></td>
	</tr>
	<tr>
		<td height="21" background="images/index_08.jpg">
			<span style="font-size:8pt; letter-spacing:1;"><font face="tahoma" color="white">&nbsp;&nbsp;<a href="ligue.php">ligue 1</font></span></td>
	</tr>
	<tr>
		<td height="19" background="images/index_09.jpg">
			<span style="font-size:8pt; letter-spacing:1;"><font face="tahoma" color="white">&nbsp;&nbsp;<a href="coupes.php">coupes</font></span></td>
	</tr>
	<tr>
		<td height="21" background="images/index_10.jpg">
			<span style="font-size:8pt; letter-spacing:1;"><font face="tahoma" color="white">&nbsp;&nbsp;<a href="contact.php">contact</a></font></span></td>
	</tr>
	<tr>
		<td height="21" background="images/index_11.jpg">
			<span style="font-size:8pt; letter-spacing:1;"><font face="tahoma" color="white">&nbsp;&nbsp;<a href="forum.php">forum</a></font></span></td>
	</tr>
	<tr>
		<td height="21" background="images/index_12.jpg">
			<span style="font-size:8pt; letter-spacing:1;"><font face="tahoma" color="white">&nbsp;&nbsp;<a href="inscription">inscription au site</a></font></span></td>
	</tr>
	<tr>
		<td>
			<img src="images/index_13.jpg" width=189 height=57 alt=""></td>
		<td>
			<img src="images/index_14.jpg" width=273 border=0 height=57 alt="" usemap="#imagemap1"></td>
	</tr>
	<tr>
		<td colspan=3>
			<img src="images/index_15.jpg" width=751 height=10 alt=""></td>
	</tr>
	<tr>
		<td background="images/index_16.jpg">
			&nbsp;</td>
		<td colspan=3>
<div id=lipsum>
<p style="margin-left: 8px; margin-right: 8px" align=justify><span 
style="font-size: 8pt; letter-spacing: 1px"><font face="tahoma"><br>ce qu'il faut mettre<br>&nbsp;</font></span></p></div></td>
		<td background="images/index_18.jpg">
			&nbsp;</td>
	</tr>
	<tr>
		<td>
			<img src="images/index_19.jpg" width=24 height=19 alt=""></td>
		<td colspan=3>
			<img src="images/index_20.jpg" width=751 height=19 alt=""></td>
		<td>
			<img src="images/index_21.jpg" width=25 height=19 alt=""></td>
	</tr>
</table>
<!-- end imageready slices --><map name="imagemap1">
<area shape="rect" coords="146, 43, 269, 55" href="http://www.kitgratos.net" target="_blank">
</map></body>
</html>


merci de votre aide

Vous êtes demandeur d'emploi ?
Sans diplôme post-bac ?

Devenez Développeur web junior

Je postule
Formation
en ligne
Financée
à 100%
16 août 2009 à 18:46:35

Essaye comme ça

<link rel="stylesheet" media="screen" type="text/css" title="style" href="style.css"/>
Anonyme
16 août 2009 à 19:15:34

CA NE MARCHE PAS DSL
Anonyme
16 août 2009 à 19:22:22

Tu as mis le CSS et l'HTML dans le même dossier ?
17 août 2009 à 16:39:24

1) Fais attention, la touche majuscule de ton clavier a l'air activée.
2) Donne nous l'arborescence de tes fichiers pour qu'on voie si le chemin vers le CSS est bon. Il y a de grandes chances que l'erreur vienne de là.
18 août 2009 à 13:26:37

Bonjour,
Ajoute également un doctype avant ton html, comme par exemple :

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
Il n'y a pas de mauvais navigateur, il n'y a que du mauvais code !
17 novembre 2017 à 20:57:57

Bonsoir ,

Avec méthode du cours <link rel="stylesheet" href="style.css" /> rien ne fonctionnait et en ajoutant type="text/css", méthode de phil836, impeccable. Pourtant mes dossiers sont ensembles, le css enregistré en format .css avec nom.css. Je n'ai pas encore compris le problème mais ça fonctionne! Merci.

11 janvier 2018 à 21:58:16

Bonsoir la communauté, 

J'ai essayé la technique de phil836, mais cela ne fonctionne pas j'ai double check tout ce qui est mentionné plus haut. 

 

11 janvier 2018 à 22:02:06

Hello,

Tu poste dans un sujet de 2009 ? ^^

Créée ton propre sujet pour avoir plus de réponses :

- Utilises l'icône </> de l'éditeur + choix du langage pour poser tes codes html/css

- Vérifier : chemin d'accès au fichier, extension du fichier, orthographie 

- utilises toujours des minuscules pour tes noms de fichiers, dossiers, images pour éviter certains souci d'orthographie 

- Remplace les espaces dans les noms par tirets - ou undescore _ , bonne pratique à apprendre, surtout en cas d' hébergement d'un site qui est souvent  sous environnement Linux côté pack hébergeur en mutualisé...

- Travailler avec la console web de ton navigateur.

- Utiliser le validateur en ligne : https://validator.w3.org/ 

Avec tout cela tu es armée pour te débrouiller tout-e seul-e

Et enfin il manque le point virgule ;

h1{
  color: yellow;
}



-
Edité par Lucky13 11 janvier 2018 à 22:08:33

11 janvier 2018 à 22:06:51

Salut, 

Oui je sais mais il y a un autre post de 2017, donc je me suis dit why not! ^^

Merci pour le point virgule.

Par contre il n'y a pas d'icône... j'utilise simple text et chrome pour info :snif:

-
Edité par ChoupinetteBatemanII 11 janvier 2018 à 22:08:48

Staff 11 janvier 2018 à 22:09:27

Le message qui suit est une réponse automatique activée par un membre de l'équipe. Les réponses automatiques leur permettent d'éviter d'avoir à répéter de nombreuses fois la même chose ce qui leur fait gagner du temps et leur permet de s'occuper des sujets qui méritent plus d'attention plus facilement.
Nous sommes néanmoins ouverts et si vous avez une question ou une remarque, n'hésitez pas à contacter la personne en question par Message Privé.

Pour plus d'informations, nous vous invitons à lire les règles générales du forum

Déterrage

Citation des règles générales du forum :

Avant de poster, demandez-vous si ce que vous allez dire apporte quelque chose au sujet. Si votre message n'apporte rien, vous ferez perdre du temps à tout le monde et le sujet pourrait dévier ou devenir difficile à suivre.

Aussi, vérifiez la date du topic. Le déterrage de topic nuit au bon fonctionnement du forum et est interdit. Utilisez les boutons pouce en haut pour dire merci. Si le topic date de plus de deux mois sans réponses, mieux vaut ne pas répondre.

Et ce, même si quelqu'un d'autre a déterré avant vous. Ce n'est pas parce que quelqu'un fait de quelque chose de déconseillé qu'il faut forcément le suivre.

Je ferme ce topic.

-
Edité par Lamecarlate 11 janvier 2018 à 22:10:17

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!