Partage
  • Partager sur Facebook
  • Partager sur Twitter

[TOPIC UNIQUE] Archlinux

Voir règles et introduction à Arch en premier post.

    31 janvier 2009 à 19:29:51

    Vous avez besoin d'aide, de conseils ou d'avis sur la distribution archlinux (pour les anglophobes: http://archlinux.fr/)?

    logo archlinux

    Ce poste est fait pour vous. Que vous soyez newbie ou utilisateur avancé, vous y retrouver toute la communauté Archlinux du site du zéro, réunit sous son magnifique logo.

    Informations et tutos rapides



    A propos des wikis d'ArchLinux: http://www.siteduzero.com/forum-83-365 [...] html#r3511033

    Informations diverses à propos de l'installation/configuration d'ArchLinux: http://www.siteduzero.com/forum-83-365 [...] html#r3410806

    Les commandes pacman et yaourt - créer un paquet à partir d'une installe actuelle: http://www.siteduzero.com/forum-83-365 [...] html#r3539181

    Dépôt AUR et AUR vote: http://www.siteduzero.com/forum-83-365 [...] html#r3550773
    A propos du 64 bit: http://www.siteduzero.com/forum-83-365 [...] html#r3389929

    Configuration du serveur X: http://www.siteduzero.com/forum-83-365 [...] html#r3412506
    Configuration du clavier avec X: http://www.siteduzero.com/forum-83-365 [...] html#r3437696

    Configurer son clavier en Azert :
    http://www.siteduzero.com/forum-83-365 [...] html#r3525517

    Optimiser Pacman avec pacman-cage :
    http://www.siteduzero.com/forum-83-365 [...] html#r3674584
    Suite :http://www.siteduzero.com/forum-83-365 [...] html#r3711253

    Les problèmes


    Résolus


    Clavier: http://www.siteduzero.com/forum-83-365 [...] html#r3387740
    Réponse: http://www.siteduzero.com/forum-83-365 [...] html#r3387811

    Installation des bibliothèques de développement (GTK+, SDL) et Montage des périphériques de stockage (USB, CDROM) (réponse dans le post suivant): http://www.siteduzero.com/forum-83-365 [...] html#r3554038

    KDE ne démmare plus! : http://www.siteduzero.com/forum-83-365 [...] html#r3868945
    Conflit des gestionnaires de fichiers : (réponse à la suite ) http://www.siteduzero.com/forum-83-365 [...] html#r5926910

    En cours


    Problèmes de son (Alsamixer) : http://www.siteduzero.com/forum-83-365 [...] html#r3525037
    Ralentissement sous Firefox lors du surf : http://www.siteduzero.com/forum-83-365 [...] html#r3525037
    http://www.siteduzero.com/forum-83-365 [...] html#r3525037

    Autres lien



    Le topic unique Gentoo (d'autres suivront peut-être):
    http://www.siteduzero.com/forum-83-382 [...] e-gentoo.html
    Le topic de recensement des zéros sous linux:
    http://www.siteduzero.com/forum-83-284 [...] istiques.html
    Le topic "vos bureaux", parce que Arch est une distribution dont la beauté mérite d'être exhibée au monde : http://www.siteduzero.com/forum-83-103 [...] -bureaux.html


    Règles



    Afin de conserver une atmosphère conviviale et de faciliter ma tâche d'administration, veuillez
    indiquer à la fin de vos posts, si et seulement si vous avez un problème résolut, en rouge et italique: le problème et en vert et gras: la solution.
    Ce topic n'est en aucun cas un lieu pour troller, ni pour demander des conseils sur une autre distribution qu'Archlinux. Cependant, on peut concevoir des discussions entre les utilisateurs qui soient off topic, mais seulement si elles n'entravent pas la marche du topic, auquel cas je ferais appel à un modérateur.


    Il n'existe pas (encore) de topic unique pour votre distribution favorite?



    Deux solutions s'offrent à vous :
    • Prendre sur vous pour créer celui-ci, et m'en informer afin que je l'ajoute dans le résaux. Toutefois, pour être lié avec ce groupe de topics il faut que votre présentation se calque sur la mienne.
    • Me demander de créer le topic. Attention, je ne créerais de topic que si a) j'y vois un interret (les distributions dites grand publique, à instalation graphique, ne seront pas supportés) et b) j'ai le temps et vous vous chargez d'organiser la discussion, en me rapportant par MP les avancés tous les mois/semaines.

    Merci d'avance!

    Ce logo archlinux est une création de addiKT1ve publié sur son blog.
    • Partager sur Facebook
    • Partager sur Twitter
      31 janvier 2009 à 19:46:30

      AMHA, ce serait mieux dans la catégorie "Linux". ;)
      • Partager sur Facebook
      • Partager sur Twitter
      Anonyme
        31 janvier 2009 à 21:02:48

        Citation : plebraly

        Bon quelqu'un connaît un moyen de passer de OpenSuse à Archlinux sans connexion? Ou alors de faire passer le WPA sur OpenSuse, pour passer ensuite à Arch?



        Nan je sais pas, pour répondre à ta questions :D Désolé. Je n'utilisa d'ailleur pas le WiFi. Ethernet Forever xD
        • Partager sur Facebook
        • Partager sur Twitter
          31 janvier 2009 à 21:29:25

          Nan, je parlais de ma 2ème question. L'instal me dit:
          GNU GRUB version 0.97 [...]
          grub>
          Je sais pas quoi tapper après grub.
          • Partager sur Facebook
          • Partager sur Twitter
          Anonyme
            31 janvier 2009 à 21:35:24

            Moi non plus... j'ai jamais manipulé le GRUB en fait xD

            Au fait qui avait demandé quoi à propos d'ArchLinux déjà ? Le temps d'installation non ? 4 heures environ, en installant Xorg, KDE ou GNOME ou autre-chose et quelques logiciels nécessaires.
            • Partager sur Facebook
            • Partager sur Twitter
              31 janvier 2009 à 22:04:10

              Comment tu as installé arch sans le grub?
              • Partager sur Facebook
              • Partager sur Twitter
              Anonyme
                31 janvier 2009 à 22:38:20

                Ah si il est installé mais je n'ai rien modifié d'autre que le timeout. Je fais pas de dualboot :)

                Au fait je voit pas ce que tu veux dire quand tu parle de passer de OpenSUSE à Arch sans connexion... en gros tu veux garder les programmes installés sous OpenSUSE pour qu'ils fonctionnent sous Arch ? Jcrois pas que ce soit possible.
                • Partager sur Facebook
                • Partager sur Twitter
                  31 janvier 2009 à 22:40:00

                  moi non plus, c'est cela que je ne comprends pas. Je boote sur le CD, et je tombe sur grub.
                  • Partager sur Facebook
                  • Partager sur Twitter
                  Anonyme
                    31 janvier 2009 à 22:43:30

                    Ah donc c'est le CD qui bug donc ?
                    • Partager sur Facebook
                    • Partager sur Twitter
                      31 janvier 2009 à 22:43:46

                      Ce n'est pas clair, tu veux dire que quand tu bootes sur le CD d'install, il te propulse sur la ligne de commande grub?
                      • Partager sur Facebook
                      • Partager sur Twitter
                        31 janvier 2009 à 22:52:43

                        Exact. Mon ordi n'est pas très récent, et l'iso est archlinux2008.06-core-i686.iso. Le pC à été livré sous XP.
                        • Partager sur Facebook
                        • Partager sur Twitter
                          31 janvier 2009 à 23:05:50

                          Hum, Essaie de booter normalement genre:
                          root (hd0,0)
                          kernel /boot/vmlinux26
                          initrd /boot/kernel26.img
                          boot

                          Adapte les noms des fichiers si ça marche pas, mais je te conseille de refaire une gravure en 8x on sera fixés.
                          • Partager sur Facebook
                          • Partager sur Twitter
                            31 janvier 2009 à 23:17:55

                            j'ai gravé en 4x la. Je teste
                            Bon alors:
                            1er: filsystem type unknown.
                            2ème: Cannot mount selected partition
                            3ème: Unerecognized command
                            et dernier Kernel must be loaded... ('en gros le 3 doit avoir marché je crois pour pouvoir le faire)/
                            • Partager sur Facebook
                            • Partager sur Twitter
                            Anonyme
                              31 janvier 2009 à 23:48:23

                              Citation : plebraly

                              Comment tu as installé arch sans le grub?

                              Il suffit de ne pas utiliser le menu "Install Bootloader" à l'installation de Arch :)

                              EDIT : L'install de arch impose le formatage de la partition donc non il n'est pas possible de conserver ses programmes ; ce qui n'est pas si mal puisqu'ils pourront alors être mis à jour avec pacman.
                              • Partager sur Facebook
                              • Partager sur Twitter
                                31 janvier 2009 à 23:59:22

                                mais OSEF. J'ai un CD arch qui me balance cela dès le début. J'ai pas besoin de garder mes progs parce que le pc est sous XP. J'arrive sur GRUB sans aucun choix.
                                • Partager sur Facebook
                                • Partager sur Twitter
                                Anonyme
                                  1 février 2009 à 0:07:37

                                  Alors là quand même c'est franchement zarb... et retélécharger un ISO ne servirait sans doute à rien...

                                  Au pire, DL Gparted, supprime tt les partitions et réessaye :(
                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                    1 février 2009 à 0:08:36

                                    sans OS, supprimer des partitions? C'est possible?
                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                    Anonyme
                                      1 février 2009 à 0:12:24

                                      Ah oui oui ! GParted :) Un Debian Like qui ne sert qu'à partitionner :) C'est un liveCD quoi :-°
                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                      Anonyme
                                        1 février 2009 à 0:19:20

                                        Citation : Schtroumpfette

                                        Au fait qui avait demandé quoi à propos d'ArchLinux déjà ? Le temps d'installation non ? 4 heures environ, en installant Xorg, KDE ou GNOME ou autre-chose et quelques logiciels nécessaires.


                                        En sachant précisément ce que l'on veut et avec une connexion correcte c'est bien plus rapide :
                                        - environ 15 minutes pour booter sur le CD d'install, installer le système de base et rebooter.
                                        - 30 minutes pour pacman -Syu, installer xorg et tous les logiciels nécessaires (y compris aller récupérer les urls des dépots KDEmod avec links), configurer sudo, networkmanager et mettre les daemons qui vont bien dans le rc.conf et consorts et rebooter.
                                        - encore 20 bonnes minutes pour fignoler son environnement si on a pas importé directement son .kde/ ou autre, et installer les trucs que l'on aura zappé.

                                        À ma connaissance il n'existe pas de système de paquetage plus rapide que pacman et son format tout bête (btw créer son propre paquet est encouragé et d'une simplicité enfantine). Ceux qui viennent de Debian sont agréablement surpris, ceux qui viennent d'une distro avec des RPMs orgasment.
                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                        Anonyme
                                          1 février 2009 à 0:26:17

                                          "ceux qui viennent d'une distro avec des RPMs orgasment. " xD C'est mon cas xD

                                          Vois-tu c'était ma première installation et je me suis un peu bagarré avec le wiki que j'avais copié/collé dans un fichier texte sur ma clé USB, les repos et aussi. Après un pti blem avec Xorg, puis KDM (daemon pas lancé au démarrage de la machine) et py c tout.

                                          Mais maintennat j'irais beaucoup plus vite sachant exactement ce qu'il faut faire ^^
                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            1 février 2009 à 0:33:03

                                            Image utilisateur

                                            C'est plus joli en transparent ^^
                                            • Partager sur Facebook
                                            • Partager sur Twitter
                                            Anonyme
                                              1 février 2009 à 0:35:59

                                              Alors toi vraiment xD

                                              Tu veux pas plutot aider notre plebraly ^^
                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                1 février 2009 à 0:46:56

                                                Tu peux me filer la source de ton image, parce que j'ai mis les zUps mais tu risque de supprimer cela un jour.
                                                • Partager sur Facebook
                                                • Partager sur Twitter
                                                  1 février 2009 à 1:04:09

                                                  J'ai pris l'originale et je l'ai modifiée avec The Gimp donc t'as qu'à la zUploader toi même :D
                                                  • Partager sur Facebook
                                                  • Partager sur Twitter
                                                    1 février 2009 à 1:59:32

                                                    Cela ne m'aide pas dans mon autre problême. Je vais l'héberger sur un hébergeur pour le topic.
                                                    • Partager sur Facebook
                                                    • Partager sur Twitter
                                                      1 février 2009 à 6:06:04

                                                      Citation : plebraly

                                                      j'ai gravé en 4x la. Je teste
                                                      Bon alors:
                                                      1er: filsystem type unknown.
                                                      2ème: Cannot mount selected partition
                                                      3ème: Unerecognized command
                                                      et dernier Kernel must be loaded... ('en gros le 3 doit avoir marché je crois pour pouvoir le faire)/


                                                      peut-tu nous dire à quel point il est vieux ton pc? car s'il n'a pas assez de ram, tu peux toujours tenter avec un cd de low-arch...

                                                      ceci dit, avec une chroot install, j'installe le tout en 15 minutes top chrono ;) (plus le transfère d'un /home avec quelques préconfigurations basiques)
                                                      • Partager sur Facebook
                                                      • Partager sur Twitter
                                                        1 février 2009 à 10:29:26

                                                        Ben il est pas très vieux, été 2002 ou 2003, MEDION, et il faisait tourner XP sans problème. Par contre à mes premiers temps linuxien, j'ai jamais réussi à instaler Ubuntu.
                                                        • Partager sur Facebook
                                                        • Partager sur Twitter
                                                        Anonyme
                                                          1 février 2009 à 11:16:18

                                                          Ca donnait quoi à l'install d'Ubuntu ? T'avais peut-être pas assez de RAM pour le lancer. Si tu en as moins de 400 je crois c'est mort...
                                                          • Partager sur Facebook
                                                          • Partager sur Twitter
                                                            1 février 2009 à 11:27:26

                                                            Je vais peut-être sauter le pas d'ici peu ^^
                                                            J'avais déja fait un test il y a quelques mois, mais j'avais pas les compétences necessaires je pense :S

                                                            J'ai testé Ubuntu, Debian Etch & Lenny, et là Fedora.
                                                            Fedora c'est sympa mais yum a du mal jtrouve :/

                                                            Enfin, assez raconté ma vie :p

                                                            Jvoudrais savoir si il est possible d'avoir la config clavier en Azerty, et TOUT le système en Anglais.
                                                            Si c'est possible, je choisi Anglais (UK) ou plutot Anglais (US)
                                                            (Je veux avoir mon OS totalement en Anglais afin de me perfectionner dans cette langue ^^)

                                                            Merci à ceux qui seront me répondre :)

                                                            Bonne journée !
                                                            • Partager sur Facebook
                                                            • Partager sur Twitter
                                                            Anonyme
                                                              1 février 2009 à 11:39:47

                                                              Pour cela tu vas dans /etc/rc.conf et dans les premières lignes tu édite fr_FR.utf8 à la place de en_EN.utf8, keymap = "fr" et par contre n'installe aucun paquet de langue forcément xD

                                                              Mon rc.conf:

                                                              LOCALE="fr_FR.utf8"
                                                              HARDWARECLOCK="localtime"
                                                              USEDIRECTISA="no"
                                                              TIMEZONE="Europe/Paris"
                                                              KEYMAP="fr"
                                                              CONSOLEFONT="lat9w-16"
                                                              CONSOLEMAP=
                                                              USECOLOR="yes"


                                                              Ensuite dans /etc/locale.gen, décommente la ligne qui correspond à la langue que tu veux avoir pour ton système, et ensuite lance la commande en root: locale -gen, relogue toi et c'est finit !

                                                              Ah et si tu veux le clavier en français, ce grâce au fichier de configuration du serveur X, modifier suivant ce post: http://www.siteduzero.com/forum-83-365 [...] html#r3437696

                                                              Voilà voilà ^^
                                                              • Partager sur Facebook
                                                              • Partager sur Twitter

                                                              [TOPIC UNIQUE] Archlinux

                                                              × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                              × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                                              • Editeur
                                                              • Markdown