• 10 hours
  • Medium

Free online content available in this course.

course.header.alt.is_video

course.header.alt.is_certifying

Got it!

Last updated on 11/15/22

Configurez EIGRP

Log in or subscribe for free to enjoy all this course has to offer!

Bienvenue à tous dans ce nouveau chapitre où vous mettrez en pratique ce que vous avez appris sur EIGRP. Une fois ce chapitre terminé, vous serez en mesure d'installer et de paramétrer un réseau interne du lancement du projet à la réalisation. Vous êtes prêts ?

Mettez-vous dans la peau d'un fournisseur d'accès Internet

Vous avez, dans les chapitres précédents, configuré votre LAN. Vous allez maintenant rendre votre WAN, c'est-à-dire votre adresse publique, visible depuis les autres routeurs du réseau. Ainsi, les utilisateurs du NET auront accès aux serveurs du data center.

Vous vous souvenez que vous aviez configuré un PC comme utilisateur d'Internet ? Cette fois-ci, vous n'allez pas le simuler, mais le faire comme il est fait dans la réalité.

Vous allez vous mettre dans la peau d'un fournisseur d'accès Internet (FAI), comme Free ou Orange.

Créez votre réseau interne

Votre travail est donc de relier les utilisateurs d'Internet entre eux. Dans cette configuration, le data center et l’utilisateur utilisant une BOX seront placés au même niveau.

Vous allez donc placer un PC pour le simple utilisateur d'Internet, le relier à un routeur (une BOX) puis ajouter entre le routeur 1 et la BOX quelques routeurs comme ceci :

schéma du réseau interne

Vous allez maintenant configurer EIGRP sur chaque routeur.

Configurez EIGRP sur les routeurs 2, 3 et 4

Commencez par les trois routeurs au centre du réseau (routeurs 2, 3 et 4) :

Routeur2(config)#router eigrp 1

Avec ces commandes, vous créez un AS (système autonome), que vous pouvez voir comme un groupe, et lui attribuez le numéro 1. Seuls les routeurs ayant été configurés avec cet AS seront associés comme voisins.

routeur2(config-router)#no auto-summary

De base, l’agrégation d'adresse est déjà configurée sur les appareils CISCO. Vous allez la désactiver, car ces adresses peuvent se simplifier.

Vous ne savez pas ce qu’est l’agrégation d’adresse ? C’est un principe assez simple à comprendre. Pour réduire le nombre d’entrées dans sa table de routage, EIGRP va simplifier les réseaux, lorsque cela est possible. Il va prendre deux sous-réseaux, ou plus, et les mélanger pour ne faire qu’un seul réseau plus important. Ainsi avec les réseaux : 223.0.1.0/24, 223.0.2.0/24, il pourrait ne créer qu’un seul réseau 223.0.1.0/23. Cela peut être utile dans certains cas, mais dans le nôtre, il existe bel et bien un réseau 223.0.0.0/24 et il ne doit pas être confondu avec un autre.

routeur2(config-router)#network 223.0.0.0
routeur2(config-router)#network 223.0.1.0
routeur2(config-router)#network 223.0.2.0

Ici, vous ajoutez les réseaux correspondants à vos interfaces. EIGRP tentera de se connecter à tous les voisins sur ces réseaux et transmettra les informations de vos réseaux à vos voisins.

Faites la même chose pour les routeurs 3 et 4.

routeur3(config)#router eigrp 1
routeur3(config-router)#no auto-summary
routeur3(config-router)#network 223.0.2.0
routeur3(config-router)#network 223.0.3.0
routeur4(config)#router eigrp 1 
routeur4(config-router)#no auto-summary 
routeur4(config-router)#network 223.0.1.0 
routeur4(config-router)#network 223.0.3.0 
routeur4(config-router)#network 223.0.5.0

Comme vous le voyez, nous avons configuré EIGRP sur chaque interface connectée à des WAN. Pour le routeur 1 et la BOX composée aussi de LAN vous devrez faire la même opération, mais sans ajouter le LAN.

Configurez EIRPG sur la BOX et le routeur 1

Connectez-vous donc au routeur 1 et entrez ces commandes :

routeur1(config)#router eigrp 1
routeur1(config-router)#no auto-summary
routeur1(config-router)#network 223.0.0.0

Puis sur la BOX :

BOX(config)#router eigrp 1 
BOX(config-router)#no auto-summary 
BOX(config-router)#network 223.0.5.0

Pourquoi ne pas avoir ajouté le réseau LAN du routeur 1 et de la BOX ?

La raison est la suivante : en ajoutant un réseau privé dans EIGRP, celui-là sera bien transmis aux autres routeurs et tous sauront comment s’y rendre. Le problème est que ce réseau privé est bien souvent composé des mêmes plages d’adresses. Le LAN de votre voisin ou d’un habitant d’une autre ville sera sûrement en 192.168.0.0/24 ou 10.0.0.0/24. Et si ce réseau est qualifié privé, c’est qu’il ne doit pas être connu du réseau public (c’est le NAT que nous avons vu qui s’en charge). Si c’était le cas, les routeurs se retrouveraient avec plusieurs chemins pour un même réseau. Pour faire le parallèle avec votre GPS, imaginez entrer une adresse et que le GPS vous propose, au choix, d’aller dans chaque maison de France.

Vérifier la configuration d’EIRPG

Avant d’effectuer un PING pour vérifier que l’EIGRP est bien configuré, jetons un œil à la configuration. Connectez-vous au routeur 2 et entrez ces commandes :

routeur2#show ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 1"
 Outgoing update filter list for all interfaces is not set
 Incoming update filter list for all interfaces is not set
 Default networks flagged in outgoing updates
 Default networks accepted from incoming updates
 EIGRP-IPv4 Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 223.0.2.2
    Topology : 0 (base)
     Active Timer: 3 min
     Distance: internal 90 external 170
     Maximum path: 4
     Maximum hopcount 100
     Maximum metric variance 1

 Automatic Summarization: disabled
 Maximum path: 4
 Routing for Networks:
    223.0.0.0
    223.0.1.0
    223.0.2.0
 Routing Information Sources:
    Gateway         Distance      Last Update
    223.0.1.4             90      00:00:10
    223.0.2.3             90      00:00:10

Le résultat de cette commande montre que le protocole EIRPG est bien actif, connecté sur les réseaux 223.0.0.0, 223.0.1.0 et 223.0.2.0. Il s’agit bien des trois réseaux autour du routeur 2. Vous pouvez voir aussi deux gateways (passerelles), l’une sur le routeur 3 et l’autre sur le routeur 4. Si le routeur 1 n’est pas une gateway, c’est qu’il n'emmène le routeur 2 vers aucune autre IP publique. Pour le comparer à votre GPS, le routeur 1 est un « cul-de-sac », vous n'empruntez ce chemin que pour vous rendre à l’adresse 223.0.0.1.

Allons maintenant voir qui sont vos voisins.

routeur2#show ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT RTO Q Seq
(sec)         (ms)       Cnt Num
2   223.0.0.1               Gi0/0                    11 00:01:16    1  5000  1 14
0   223.0.1.4               Gi0/2                    14 00:10:01  290 1740 0 32
1   223.0.2.3               Gi0/1                    12 00:12:11  279 1674 0 34

Cette commande vous permet de voir la liste du voisinage du routeur. Découvrons en détail les informations qui nous sont apportées ici :

  • Tout d’abord il vous indique qu’il s’agit de l’AS 1.

  • Ensuite de gauche à droite il indique :

    • l’adresse des voisins ;

    • L’interface (du routeur sur lequel on lance la commande) sur laquelle ils sont connectés.

    • Le temps restant (hold) avant que le voisin soit déclaré down (15 secondes par défaut).

    • Le temps écoulé (uptime) depuis que le routeur local a établi un lien avec le voisin (utile pour découvrir des pannes).

    • Le nombre de millisecondes pour envoyer un paquet EIGRP et recevoir l’accusé de réception (SRTT).

    • Le délai de retransmission d’un paquet lorsqu’il n’a pas accusé réception (RTO).

    • Le nombre de paquets EIGRP en attente d’être envoyés (Q).

    • Le numéro de la dernière mise à jour (Seq).

Comme vous pouvez vous en douter, cette commande est très utile pour le débogage. Il est facile de se rendre compte des problèmes entre deux routeurs :

  • si le uptime est très petit (problème de connexion ou reboot),

  • que le SRTT est très grand (problème de bande passante)

  • ou encore que le Q contient des paquets en attente.

C’est le cas ici avec le routeur connecté au réseau 223.0.0.1 (le routeur 1).

Ensuite, intéressons-nous à la topologie du réseau. Vous allez rentrer cette commande :

routeur2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(223.0.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 223.0.3.0/24, 2 successors, FD is 3072
via 223.0.1.4 (3072/2816), GigabitEthernet0/2
via 223.0.2.3 (3072/2816), GigabitEthernet0/1
P 223.0.0.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/0
P 223.0.2.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/1
P 223.0.4.0/24, 1 successors, FD is 3072
via 223.0.1.4 (3072/2816), GigabitEthernet0/2
P 223.0.1.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/2

Vous pouvez voir que pour se rendre au réseau 223.0.3.0/24 le routeur 2 a deux chemins : l’un en passant par le routeur 4 (223.0.1.4), l’autre en passant par le routeur 3 (223.0.2.3). Regardons son choix grâce à la commande :show ip route.

routeur2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set
     223.0.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        223.0.0.0/24 is directly connected, GigabitEthernet0/0
L        223.0.0.2/32 is directly connected, GigabitEthernet0/0
223.0.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        223.0.1.0/24 is directly connected, GigabitEthernet0/2
L        223.0.1.2/32 is directly connected, GigabitEthernet0/2
223.0.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        223.0.2.0/24 is directly connected, GigabitEthernet0/1
L        223.0.2.2/32 is directly connected, GigabitEthernet0/1
D     223.0.3.0/24 [90/3072] via 223.0.2.3, 00:42:51, GigabitEthernet0/1
[90/3072] via 223.0.1.4, 00:42:51, GigabitEthernet0/2
D     223.0.4.0/24 [90/3072] via 223.0.1.4, 00:42:46, GigabitEthernet0/

Vous pouvez voir par cette commande quels chemins sont empruntés pour aller vers un réseau. Ici, vous voyez que pour se rendre au réseau 223.0.3.0/24, EIGRP choisit de passer par 223.0.2.3 (le routeur 3) et qu’il garde une route de secours par le routeur 4.

Votre réseau interne est maintenant configuré ! Chaque routeur a connaissance du réseau et est donc en mesure de transmettre un paquet vers le bon routeur et cela en choisissant le meilleur chemin possible. Il ne vous reste plus qu’à configurer la BOX afin de donner accès à Internet à l’Utilisateur_Internet et ainsi lui permettre d’acheter sur le site d’e-commerce. Si vous vous sentez prêt, essayez par vous-même avant d’aller voir la marche à suivre dans le chapitre suivant. Si vous préférez être guidé étape par étape, rendez-vous au prochain chapitre !

Donnez accès à Internet au simple utilisateur et validez votre topologie

C’est la dernière étape avant de voir votre topologie terminée. Il s’agit en fait de configurer la BOX de la même façon que le routeur 1, mais sans VLAN. Vous connaissez les commandes, mais je vous les redonne. La répétition des exercices est une bonne chose pour la mémoire.

Il s’agit de configurer l’interface, le NAT, la route par défaut ainsi que le DHCP et votre BOX est prêt à l’emploi.

Configurez l’interface

Vous devez d’abord ajouter une interface avec une adresse privée, entre la BOX et les PC. Je vous propose cette adresse : 192.168.0.254/24.

BOX#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
BOX(config)#interface gi0/0/0
BOX(config-if)#ip address 192.168.0.254 255.255.255.0
BOX(config-if)#no shutdown
BOX(config-if)#exi

Vous pouvez maintenant passer au DHCP.

Configurez le DHCP

BOX#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
BOX(config)#service dhcp
BOX(config)#ip dhcp pool BOX
BOX(dhcp-config)#network 192.168.0.0 255.255.255.0
BOX(dhcp-config)#default-router 192.168.0.254

Le premier PC à se connecter obtiendra l’adresse 192.168.0.1/24.

Passons maintenant à la route par défaut et au NAT pour donner accès à Internet aux utilisateurs.

Configurez l’accès à Internet

BOX(config)#ip access-list standard BOX
BOX(config-std-nacl)#permit 192.168.0.0 0.0.0.255
BOX(config-std-nacl)#exit

Commencez par créer une liste d’accès : celle de votre pool DHCP.

BOX(config)#int gi0/0/0
BOX(config-if)#ip nat outside
BOX(config-if)#exit

Vous allez pouvoir ensuite configurer le WAN comme la sortie du NAT.

BOX(config)#int gi0/0/0
BOX(config-if)#ip nat inside
BOX(config-if)#exit

Et le LAN comme l’entrée du NAT.

BOX(config)#ip nat inside source list BOX interface gigabitEthernet0/0/1 overload

Enfin, autorisez la liste BOX à utiliser le NAT.

BOX#copy run start

Sauvegardez votre configuration, lorsque vous êtes sûres de vous.

Il ne vous manque plus qu’à lancer un PING depuis l’Utilisateur_Internet vers le site d’e-commerce qui a pour adresse publique 223.0.0.1.

PC> ping 223.0.0.1

Et voilà le résultat :

84 bytes from 223.0.0.1 icmp_seq=1 ttl=60 time=240.751 ms
84 bytes from 223.0.0.1 icmp_seq=2 ttl=60 time=90.491 ms
84 bytes from 223.0.0.1 icmp_seq=3 ttl=60 time=82.656 ms
84 bytes from 223.0.0.1 icmp_seq=4 ttl=60 time=83.537 ms
84 bytes from 223.0.0.1 icmp_seq=5 ttl=60 time=96.898 ms

Vous voyez que même sans route par défaut, le l’Utilisateur_Internet a accès à Internet.

Et voilà ! Vous pouvez être fier de vous !

A cette étape du cours :

  1. vous avez créé le réseau privé d’un data center,

  2. vous l’avez ensuite connecté à un réseau public

  3. et avez rendu accessible les serveurs du data center depuis Internet.

Vous êtes donc en mesure de créer un réseau interne grâce à EIGRP de toutes pièces ! Dans le prochain chapitre, vous verrez comment faire tout cela avec le protocole OSPF.

En résumé

  • La connexion entre chaque routeur se fait entre deux interfaces de même réseau.

  • Les réseaux privés ne doivent pas être inclus dans la configuration d’EIGRP. C’est le NAT qui s’occupe de les rendre accessibles.

  • Pour configurer EIGRP sur un routeur il suffit d’entrer les commandes :

    • routeur(config)#router eigrp n° AS

    • routeur(config-router)#no auto-summary

    • routeur(config-router)#network adresse_réseau

  • On utilise la commandeno auto-summary lorsque l’on ne souhaite pas faire d’agrégation d’adresse. Cela est néanmoins utile dans certains cas.

  • La commandeshow ip protocols permet de voir si EIGRP est bien lancé.

  • La commande  show ip eigrp neighbors permet de voir les voisins d’un routeur. Cette commande est très utile pour le débogage.

  • La commandeshow ip eigrp topology  permet de voir la totalité de la topologie, c’est-à-dire tous les réseaux de votre réseau interne où EIGRP est configuré.

  • La commandeshow ip route permet de voir quelles routes sont prises pour aller vers un réseau. Elle permet aussi de voir les routes de secours.

Example of certificate of achievement
Example of certificate of achievement