• 12 heures
  • Moyenne

Ce cours est visible gratuitement en ligne.

course.header.alt.is_video

course.header.alt.is_certifying

J'ai tout compris !

Mis à jour le 07/03/2022

Réalisez le routage inter-vlan

Connectez-vous ou inscrivez-vous gratuitement pour bénéficier de toutes les fonctionnalités de ce cours !

Faites le routage inter-vlan

Dernière étape de notre périple : la configuration de notre cœur de réseau. Eh bien en fait, la configuration d’un commutateur de niveau 3 diffère très peu de la configuration d’un commutateur de niveau 2. Vous allez réaliser les mêmes étapes que précédemment, à savoir :

  1. Créer les VLAN dans le commutateur de niveau 3.

  2. Affecter les VLAN dans les différentes interfaces.

  3. Créer les liaisons Trunks et autoriser les VLAN sur ces liaisons Trunks.

Voici la réponse :

SwitchL3(config)# vlan 20
SwitchL3(config-vlan)# name Direction
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 21
SwitchL3(config-vlan)# name Examen/Concours
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 22
SwitchL3(config-vlan)# name Paie/DRH
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 23
SwitchL3(config-vlan)# name Emploi
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 24
SwitchL3(config-vlan)# name Medecine
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 25
SwitchL3(config-vlan)# name Assurance
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 27
SwitchL3(config-vlan)# name Info/RGPD
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 30
SwitchL3(config-vlan)# name Serveurs
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 40
SwitchL3(config-vlan)# name Impression
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 50
SwitchL3(config-vlan)# name Telephonie
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 60
SwitchL3(config-vlan)# name Wifi
SwitchL3(config-vlan)# exit
SwitchL3(config)# vlan 100
SwitchL3(config-vlan)# name Administration
SwitchL3(config-vlan)# exit
SwitchL3(config)# interface g1/0/2
SwitchL3(config-if)# switchport trunk encapsulation dot1q
SwitchL3(config-if)# switchport mode trunk
SwitchL3(config-if)# switchport trunk native vlan 100
SwitchL3(config-if)# switchport trunk allowed vlan 
20,21,40,50,100
SwitchL3(config-if)# exit
SwitchL3(config)# interface g1/0/3
SwitchL3(config-if)# switchport trunk encapsulation dot1q
SwitchL3(config-if)# switchport mode trunk
SwitchL3(config-if)# switchport trunk native vlan 100
SwitchL3(config-if)# switchport trunk allowed vlan 
22,23,40,50,100
SwitchL3(config-if)# exit
SwitchL3(config)# interface g1/0/4
SwitchL3(config-if)# switchport trunk encapsulation dot1q
SwitchL3(config-if)# switchport mode trunk
SwitchL3(config-if)# switchport trunk native vlan 100
SwitchL3(config-if)# switchport trunk allowed vlan 
24,25,40,50,100
SwitchL3(config-if)# exit
SwitchL3(config)# int g1/0/5
SwitchL3(config-if)# switchport trunk encapsulation dot1q
SwitchL3(config-if)# switchport mode trunk
SwitchL3(config-if)# switchport trunk native vlan 100
SwitchL3(config-if)# switchport trunk allowed vlan 
27,40,50,100
SwitchL3(config-if)# exit
SwitchL3(config)# int g1/0/6
SwitchL3(config-if)# switchport mode access
SwitchL3(config-if)# switchport access vlan 30
SwitchL3(config-if)# exit
SwitchL3(config)# int g1/0/7
SwitchL3(config-if)# switchport mode access
SwitchL3(config-if)# switchport access vlan 30
SwitchL3(config-if)# exit
SwitchL3(config)# int g1/0/8
SwitchL3(config-if)# switchport mode access
SwitchL3(config-if)# switchport access vlan 30
SwitchL3(config-if)# exit
SwitchL3(config)# int g1/0/9
SwitchL3(config-if)# switchport mode access
SwitchL3(config-if)# switchport access vlan 60
SwitchL3(config-if)# exit

Bon c’est super tout cela, mais le but d’un commutateur de niveau 3, c’est de faire du routage, non ?

Certes, vous avez configuré précédemment votre table de routage, mais il reste une configuration importante : il faut créer une passerelle pour tous les VLAN afin qu’ils puissent communiquer ensemble !

Vous allez procéder de la même manière que pour les commutateurs de niveau 2. C’est-à-dire : créer des interfaces virtuelles (SVI). Comme vous l’avez déjà fait avant, je vous donne les commandes à rentrer pour créer toutes les passerelles sur les interfaces virtuelles SVI :

SwitchL3(config)# interface vlan 20
SwitchL3(config-if)# description Passerelle SVI Direction
SwitchL3(config-if)# ip address 192.168.20.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:20::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 21
SwitchL3(config-if)# description Passerelle SVI 
Examen/Concours
SwitchL3(config-if)# ip address 192.168.21.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:21::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 22
SwitchL3(config-if)# description Passerelle SVI Paie/DRH
SwitchL3(config-if)# ip address 192.168.22.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:22::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 23
SwitchL3(config-if)# description Passerelle SVI Emploi
SwitchL3(config-if)# ip address 192.168.23.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:23::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 24
SwitchL3(config-if)# description Passerelle SVI Medecine
SwitchL3(config-if)# ip address 192.168.24.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:24::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 25
SwitchL3(config-if)# description Passerelle SVI Assurance
SwitchL3(config-if)# ip address 192.168.25.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:25::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 27
SwitchL3(config-if)# description Passerelle SVI Info/RGPD
SwitchL3(config-if)# ip address 192.168.27.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:27::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 30
SwitchL3(config-if)# description Passerelle SVI Serveurs
SwitchL3(config-if)# ip address 192.168.30.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:30::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 40
SwitchL3(config-if)# description Passerelle SVI Impression
SwitchL3(config-if)# ip address 192.168.40.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:40::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 50
SwitchL3(config-if)# description Passerelle SVI Telephonie
SwitchL3(config-if)# ip address 192.168.50.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:50::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# interface vlan 60
SwitchL3(config-if)# description Passerelle SVI Wifi
SwitchL3(config-if)# ip address 192.168.60.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:60::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit
SwitchL3(config)# int vlan 100
SwitchL3(config-if)# description Passerelle SVI Administration
SwitchL3(config-if)# ip address 192.168.100.254 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:100::254/64
SwitchL3(config-if)# no shutdown
SwitchL3(config-if)# exit

C’est bon, votre maquette sous Cisco Packet Tracer doit être totalement fonctionnelle. Pour cela il va falloir faire des tests. Je vous explique tout ça dans cette vidéo :

Allez, une petite vidéo pour tester l’accès en SSH sur un commutateur Cisco Catalyst 2960 :

Configurez votre réseau avec l’IPv6

Vous avez configuré tous les équipements d’interconnexion avec l’adressage IPv6, c’est super mais ce serait bien de s’en servir. Il faut donc maintenant configurer tous les périphériques finaux en utilisant le protocole IPv6. Il faudra donc configurer les périphériques finaux comme ceci :

  • Adresse IPv6 : 2001:db8:acad:Numéro_Sous_Réseau::NuméroPoste.

  • Préfixe IPv6 : Cela correspond au masque de sous-réseau IPv4, vous mettrez toujours le même : /64.

  • Passerelle IPv6 : Cela correspond à la passerelle par défaut IPv6.

Allez, je suis gentil, je vous montre la configuration IP complète du PC1-Dir. Vous devriez ensuite arriver à faire tout seul cette configuration sur tous les autres postes. 😉

Screenshot de l'interface Packet Tracer pour configurer les paramètre IPv6 du PC1-Dir
Configuration IP complète avec les paramètres IPv6 à Configurer. Ne touchez pas à l’adresse IPv6 Link Local (Link Local Address)

Pour l’imprimante Imp-Dir, comme pour l’IPv4, les configurations se réalisent dans 2 menus différents :

Screenshot de l'interface Packet Tracer pour configurer l'IPv6 de Imp-Dir
Configuration de l’Adresse IPv6 et du Préfixe pour une Imprimante dans Cisco Packet Tracer Menu Config → Interface → FastEthernet0
Screenshot de l'interface Packet Tracer pour configurer l'IPv6 de Imp-Dir
Configuration de la Passerelle par Défaut IPv6 pour une Imprimante dans Cisco Packet Tracer Menu Config → Global → Settings

Quand vous avez réalisé les configurations de tous les postes (et de tous les périphériques finaux WiFi), de tous les serveurs et de toutes les imprimantes, vous pouvez réaliser les tests de communication en IPv6. Je vous montre comment faire dans cette vidéo :

En résumé

Vous avez vu dans ce chapitre :

  • Le routage inter-vlans en créant

    • des VLANs dans le commutateur de niveau 3,

    • en affectant les VLANs dans le commutateur de niveau 3,

    • en créant des liaisons Trunks et en autorisant les VLANs sur ces liaisons Trunks.

  • La configuration de l’adressage IPv6 des différents postes informatiques et des différentes imprimantes (Adresses IPv6, Préfixes IPv6 et Passerelles IPv6).

Votre configuration est maintenant complètement fonctionnelle .😛 Amusez-vous à tester la communication entre tous les équipements ! Ce qui serait bien maintenant, ce serait de sauvegarder toutes ces configurations. Pas de souci, vous le verrez dans le prochain chapitre !

Exemple de certificat de réussite
Exemple de certificat de réussite